When Interruption of Existing Services on Some Data Boards of OSN Products

Keywords: MSTP, SDH, OptiX OSN 9500

Abstract: For an SSN4EGS4/SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2

board of version 2.44 or earlier, an SSN2EGT2 board of version 2.19 or earlier, and SSJ6EGT6A

board of all static versions, binding timeslots on new VCTRUNKs with LCAS enabled may

result in the interruption of existing services after the boards are warm reset.

[Problem Description]

Trigger conditions:

This problem can be identified under the following conditions:

1. A board of a preceding version is used.

2. On an SSN4EGS4 board, the fifth VC-4 timeslot or the 13th VC-4 timeslot is occupied by services.

For an SSN2EGT2/SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2/SSJ6EGT6A board,

the first VC-4 timeslot is occupied by services.

3. The last reset performed on the board is a warm reset.

4. After the board is warm reset, VC-3 timeslots (the issue is irrelevant with VC-12 or VC-4 timeslots)

are configured for a VCTRUNK and LCAS is enabled for the board (there is no requirement on the

order of enabling the LCAS function and timeslot binding).

For an SSN4EGS4 board:

If the VC-3 timeslot corresponding to any of the first to eighth VC-4 timeslots is newly bound with

services, services occupying the fifth VC-4 timeslot on the board are interrupted. If the VC-3 timeslot

corresponding to any of the 9th to 16th VC-4 timeslots is newly bound with services, services

occupying the 13th VC-4 timeslot on the board are interrupted.

For an SSN2EGT2/SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2/SSJ6EGT6A board:

If the VC-3 timeslot corresponding to ant of the first to eighth VC-4 timeslots is newly bound with services,

services occupying the first VC-4 timeslot on the board are interrupted.

Symptom:

After certain VC-3 timeslots on one of the preceding boards (which has been warm reset lately) are newly

bound with services, some existing services on the board are interrupted. The VCTRUNK corresponding

to the interrupted services reports an ALM_GFP_DLFD alarm.

Identification method:

1. An SSN4EGS4/SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2 board of version 2.44 or

earlier, an SSN2EGT2 board of version 2.19 or earlier, or an SSJ6EGT6A board of all versions is used.

2. The board has been warm reset, including warm reset after the board software is upgraded.

3. Timeslot binding is configured for the board and the configuration interrupts existing services.

The VCTRUNK corresponding to the interrupted services reports an ALM_GFP_DLFD alarm.

[Root Cause]

For an SSN4EGS4 board of version 2.44 or earlier, the software has a defect. After a warm reset,

the MST not used by any VCTRUNKs extract VC-4 timeslots that are mistakenly numbered as the

fifth or 13th VC-4 timeslot after the initialization. As a result, if another timeslot is bound, configuration

of the original fifth or 13th VC-4 timeslot is changed and the corresponding services are interrupted.

For an SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2 board of version 2.44 or earlier,

an SSN2EGT2 board of version 2.19 or earlier, or an SSJ6EGT6A board of all static versions, the

software has the same defect. If a new timeslot is bound, configuration of the original first VC-4

timeslot is changed and the corresponding services are interrupted.

[Impact and Risk]

After the board is warm reset, configuring new services may interrupt existing services. Deleting

the new services cannot recover the existing services.

[Measures and Solutions]

Recovery measures:

The existing services can be recovered by using the following methods.

Delete and re-configure the timeslot binding for the interrupted services. The LCAS function

does not need to be disabled.

Cold reset on the board.

Workarounds:

After a board configured with timeslot binding is warm reset, do not enable the LCAS function for

new VCTRUNKs if new timeslots need to be bound with services.

Solution:

Upgrade an NG SDH NE to V100R010C03SPC203 or a later version to eliminate the software defect

on an SSN4EGS4/SSN5EFS0/SSN3EFS4/SSN3EGS2/SSN1EFS0A/SSN1EMS2 board;

 

upgrade an NG SDH NE to V100R010C03SPC215 or a later version, or upgrade NGSDH NE to

V1R10C03SPC208+SPH217 or later hot patch to eliminate the software defect on an SSN2EGT2

board. V1R10C03SPH217 will be released in Aug 2014.

 

For OptiX OSN 9500, the defect has not been rectified on any static version and will be rectified

on versions later than V100R006C05SPC208. For an online issue, install V100R006C03SPH206

or a later hot patch or install V100R006C05SPH209 or a later hot patch to solve the issue.

[Inspector Applicable or Not]

Applicable.

Inspection case title: Pre-Warning Risk on Inspecting SD598 Data Boards

TwitterLinkedInGoogle+FacebookPinterestTumblrStumbleUponRedditShare

Leave a Reply

Your email address will not be published. Required fields are marked *